RBG500 combo

If you need info on Laney cabs, HH speakers or more obscure Laney products, this is the forum for you.
Old rumbler
MortalMortal
Posts: 2
Joined: Mon Dec 10, 2018 7:39 pm

RBG500 combo

Postby Old rumbler » Mon Dec 10, 2018 8:00 pm

Just picked this up, hate new amps, too 'hi-fi' for me. Everything seems to be doing what it should except the six push buttons (left and right of panel). The compressor works but LO and HI don't appear to do anything and neither do FULL, BRIGHT or HORNS. Maybe the horn is blown which would explain no change but I'd love to hear what LO and HI sound like. I had the amp section out to spray electrical clean/lube into everything necessary but I can't see the stuff getting into the push button guts. Would it work better down the holes where the buttons go through the panel and actually seep down?
Other than that, it sounds awesome even though someone appears to have cut the 15" speaker aperture slightly bigger at some point although the speaker (original? Nothing on the magnet?) sits firmly.

Old rumbler
MortalMortal
Posts: 2
Joined: Mon Dec 10, 2018 7:39 pm

Re: RBG500 combo

Postby Old rumbler » Tue Dec 11, 2018 11:07 pm

Okay, update - leant the combo backwards so the six push buttons were pointing skywards, sprayed contact cleaner/lube down the shafts and worked each button in and out and finally left overnight all pressed in.
Next evening, bingo!! The HI and LO buttons now work perfectly. Unfortunately the others (Full, Bright and Horns) still don't so I now suspect the horn has blown. Next thing is to try a couple of ways to see if there is a signal to the horn and test the horn with a meter.

Look out for the next update.

Ps took it to rehearsal tonight. Gain on 3, volume on 3, kept up with guitar, keyboard, electronic drums via monitor and vocals. Nice combo!


Return to Amps / Cabs / Mixing Desks etc

Who is online

Users browsing this forum: No registered users and 2 guests