VH100R HOT amp issue

For discussion of all current Laney amplifiers
JMusic
MortalMortal
Posts: 1
Joined: Tue Jun 11, 2019 9:43 pm

VH100R HOT amp issue

Postby JMusic » Tue Jun 11, 2019 9:51 pm

My VH100R started to get some pretty nasty noise coming from it. Afterward it would occasionally pop VERY loudly like a tube issue, but much louder than usual. The last time it did this I walked over to it and noticed an abnormal amount of heat coming from the top. The metal grill on the top was too hot to even touch. After I unplugged it and let it cool, I looked on the underside and there appears to be some plastic netting material that actually got melted.

I haven't yet replaced the tubes but I'm going to get onto it soon. Do you guys think this is just a tube issue? I hope nothing got damaged from it overheating. I turned it on a while ago and it seems fine, but I don't keep it on long enough to start doing that again.

The only mistake I remember committing is that I accidentally left my amp on without a speaker cable plugged in. That was a while back. I also don't remember if I had it on standby at the time. Do you think that would hurt it a lot, even if standby was on?

Polsky
ZeusZeus
Posts: 462
Joined: Sun Oct 30, 2016 2:15 pm
Location: Chicago , United States

Re: VH100R HOT amp issue

Postby Polsky » Fri Jul 26, 2019 4:20 pm

Yes , it could damage output transformer. You have to check if OT getting very hot. Also it could damage circuit. When amp is turned on without load, enormous voltage hitting transformer and circuit causing melting wires inside tranny. So the best way would be to check amp by technician.
Laney IRT60 H[/color][/b]
Laney AOR 5012 Series II combo.
Laney AOR 100MV[/color][/b]
Laney Linebacker 30
4x12 Cabinet Vintage30 and G1
[color=#BF0000]Laney AOR 2x12 cab.

Marlboro Ultra Light


Return to Current Laney Products

Who is online

Users browsing this forum: Google [Bot] and 8 guests